LockedImporting MySQL Databases

Author
gyrecon
Junior Member
2009/07/09 06:23:52 (permalink)

Importing MySQL Databases

I guess that ateir are certain conditions that have to be met when importing a MySQL Database, becuase when I go to do the import I get:
 
Database Type : SQL Server My-SQL Select Database Instance :   Select Database :   Select Database User : No Database User Found. Reseller Name :   Owner Name :   Associated Website :  
 
everything else is filled out except I see "No Database User Found" what user is this refering to? root? or should I create another db user with all privileges? I guess this has to be satisfied before I cn click the import button.
#1

8 Replies Related Threads

    Tahir
    HC Staff
    Re:Importing MySQL Databases 2009/07/09 09:28:22 (permalink)
    Db exist in database server does it running under their specific User or root/sa ?

    If not then try to create/assign db user on it then try to import
    #2
    gyrecon
    Junior Member
    Re:Importing MySQL Databases 2009/07/09 10:02:40 (permalink)
    are you saying that they should be under root or their own user?
    #3
    Tahir
    HC Staff
    Re:Importing MySQL Databases 2009/07/09 11:33:52 (permalink)
    Their own user
    #4
    gyrecon
    Junior Member
    Re:Importing MySQL Databases 2009/07/09 15:23:43 (permalink)
    still no luck.
    #5
    Tahir
    HC Staff
    Re:Importing MySQL Databases 2009/07/12 03:26:42 (permalink)
    Well It’s not an issue.

    A database user account is used for database access and permissions validation. So that message is shown because no database user has rights to access the selected database.

     To give rights to some database user to some database or to avoid that message follow the following steps;


    ·         Expand the "Logins" node in "Security" node in the Object Explorer of the DBMS.

    ·         Go to properties of any user you want to edit.

    ·         Select the "User Mapping" option.

    ·         Now map your selected user to the databases you want. Mapping will give rights to your database user to access these databases.

    Incase of MSSQL see the attach file

    For mysql db user permissions see instructions in this link http://www.debuntu.org/...set-privileges-to-a-user

    Hope this shall fix this issue.

    Attached Image(s)

    #6
    gyrecon
    Junior Member
    Re:Importing MySQL Databases 2010/01/08 17:09:00 (permalink)
    Still no luck, I am Using Windows Server 2008/ MySQL 5.1
    #7
    HC Team
    Hosting Controller
    Re:Importing MySQL Databases 2010/01/11 22:49:03 (permalink)
    What permissions have you set on the database for the user ?
    #8
    patrick
    Premium Member
    Re:Importing MySQL Databases 2010/01/12 03:12:05 (permalink)
    Why not to follow a simple way, take backup of the database and recreate it from HC  panel then restore original db. It will save a lot of your time :)
    #9
    Jump to: