Lockeddatabase error

Author
atakokan
Junior Member
2010/05/19 07:04:53 (permalink)

database error

I can't installation because its give error message "check your database connection information and retry" I write "hcdbadmin" and password. When I click next this message come always. I need help.

I have Windows 2008 and Microsoft SQL 2008 ENT.

Attached Image(s)

#1

10 Replies Related Threads

    patrick
    Premium Member
    Re:database error 2010/06/08 07:33:05 (permalink)
    Try to create ODBC Dsn connection, if it work then hc subsequent setup will work too.
    #2
    gt
    Junior Member
    Re:database error 2010/06/19 07:54:32 (permalink)
    I am having the same issue as atakokan. Win2008 svr, 64bit. SQL 2008.

    Tried creating ODBC connections, all test out OK. Created a test DB and another few aps worked fine with entered DB sa login used.

    Also ensured the TCP connections are enabled on standard ports and used IP address for SQL, all OK.

    Interestingly the HC prerequisite util shows the DB being OK but shows .NET not being OK. However my server has .NET 3.5 and 4 installed. When I tried to install .NET 2 the system says its already installed as part of the OS.

    #3
    Tahir
    HC Staff
    Re:database error 2010/06/21 06:17:04 (permalink)
    gt

    I am having the same issue as atakokan. Win2008 svr, 64bit. SQL 2008.

    Tried creating ODBC connections, all test out OK. Created a test DB and another few aps worked fine with entered DB sa login used.

    Also ensured the TCP connections are enabled on standard ports and used IP address for SQL, all OK.

    Interestingly the HC prerequisite util shows the DB being OK but shows .NET not being OK. However my server has .NET 3.5 and 4 installed. When I tried to install .NET 2 the system says its already installed as part of the OS.



    If ODBC connection is establishing then installer should connect to the remote sql server. Did you install HC on remote sql server machine ?
    Secondly, Turn OFF Windows firewall on both remote and local machine and then try to install see if it is allowing connection or not.

    FYI: Aspnet 4.0 version will be supported in coming service pack (build8)

    #4
    gt
    Junior Member
    Re:database error 2010/06/21 07:50:05 (permalink)
    This is not a remote server, the SQL 2008 is on the same server (Win2008svr) that I am trying to install HC8 primary server.

    Tried turning off firewall, no change.

    Do you think the fact that HC prerequisite shows .NET  not being installed even though it is will have any impact on this?
    #5
    Tahir
    HC Staff
    Re:database error 2010/06/21 07:58:40 (permalink)
    Have you install sql client services as per instructed in this Article
    Sql 2008 client services : http://hostingcontroller.com/english/forms/tech/hc/sql2k8-client.zip 


    Also make sure that you are providing sql server instance name in the installation field " Server Name "


    If it is still not working with you then we will recommend to contact our support department, you can open ticket using http://portal.hostingcontroller.com
    #6
    gt
    Junior Member
    Re:database error 2010/06/22 09:00:14 (permalink)
    Just to advise that I downloaded the file from the link, the first item would not install as it said it was not suitable for the type of processor installed. The other items installed OK, however even after this, and a server reboot, still had the same problem that HC install would not continue saying there was an issue with the database connectivity.
    #7
    Tahir
    HC Staff
    Re:database error 2010/06/24 04:17:27 (permalink)
    Please open a ticket on support and provide us the images of installation and error.
    #8
    ALBERT
    Junior Member
    Re:database error 2010/09/07 02:12:48 (permalink)
    First you have to create ODBC connection and then put user id and pwd.
    #9
    steve01
    Starting Member
    Re:database error 2010/09/20 04:39:17 (permalink)
    Make sure that you are putting correct machine name while installing HC. HC requires SQL instance name as well if you are using named instance then put server name like machine-name\sqlexpress. Also make sure that you are entering correct SA user password.
    #10
    Lauren
    Junior Member
    Re:database error 2010/12/22 08:59:43 (permalink)
    Check if you are giving the correct database server instance name. Like try servername\sqlexpress and secondly check that IP protocols and named pipes are enabled as well. You can enable protocol from sql server management studio and there you will see protocols for sql server.
    #11
    Jump to: