LockedMySQL Settings

Author
Airfox
Junior Member
2010/08/02 09:37:17 (permalink)

MySQL Settings

When adding a new Linux MySQL server it asks for the "Database Service File Path".
I'm using Ubuntu 8.0.4, which file is this? /usr/bin/mysql ? /var/lib/mysql/ibdata1 ? or something else?
 
post edited by Airfox - 2010/08/02 09:40:28
#1

4 Replies Related Threads

    steve01
    Starting Member
    Re:MySQL Settings 2010/08/02 11:19:22 (permalink)
    Use this path /etc/init.d/mysqld for Database Service File Path. I have configured this path in my HC panel and it is working smoothly.
    #2
    Airfox
    Junior Member
    Re:MySQL Settings 2010/08/03 10:09:54 (permalink)
    Thanks for that.
     
    Sadly it doesn't seam to have worked... View all databases, I get "No database found."  (obviously there are databases in there). I cant create new databases either.
     
    I think the documentation could be a little more helpful in defining exactly what files are required.
    #3
    Tahir
    HC Staff
    Re:MySQL Settings 2010/08/03 13:25:00 (permalink)
    Airfox

    Thanks for that.
     
    Sadly it doesn't seam to have worked... View all databases, I get "No database found."  (obviously there are databases in there). I cant create new databases either.
     
    I think the documentation could be a little more helpful in defining exactly what files are required.



    You can verify the mysql service path by restarting it which should be
    /etc/init.d/mysql or /etc/inti.d/mysqld


    In Debian/Ubuntu by default MySQL can not listen remotely or IP address therefore set 'bind-address' as machine IP in my.cnf file at this path/etc/mysql/my.cnf of  Linux Server.



    For more detail consult with this kb
    http://portal.hostingcontroller.com/KB/a44/how-to-fix-mysql-db-creation-issue-in-hc-linux.aspx

    #4
    Lauren
    Junior Member
    Re:MySQL Settings 2011/06/15 07:09:24 (permalink)
    You may also check the permission of the user who is viewing all these databases.
    In most case this user is the root. Just grant enough permissions to the root user. Otherwise there is no reason of not being able to view these databases;
     
    #5
    Jump to: