AnsweredLockedFail to create a runspace because you have exceeded the maximum number of connections.

Author
Xavier
Senior Member
2020/01/06 06:27:07 (permalink)

Fail to create a runspace because you have exceeded the maximum number of connections.

While working on Exchange Remote PowerShell from a non-Exchange machine, I encountered an error shown below. 
 
Fail to create a runspace because you have exceeded the maximum number of connections allowed : 18 for the policy party : MaxConcurrency. Please close existing runspace and try again.
 
Can anyone throw some light on what could be the cause of this issue and what are the probable solution to this particular problem ?
#1
Tahir
HC Staff
☼ Best Answerby Xavier 2020/01/07 06:23:39
Re: Fail to create a runspace because you have exceeded the maximum number of connections. 2020/01/07 04:05:25 (permalink)
By default maximum PowerShell connections 18 are allowed in exchange. You should create new throttle policy to allow more connections as per your application need.
 
New-ThrottlingPolicy -Name ITStaffPolicy -PowerShellMaxConcurrency 50 -ThrottlingPolicyScope Regular
 
You can associate this new policy to the service account under which the application is running
Set-ThrottlingPolicyAssociation -Identity tonysmith -ThrottlingPolicy ITStaffPolicy
 
Restart Microsoft Throttling service
 
Reference MS Article https://docs.microsoft.com/en-us/exchange/change-user-throttling-settings-for-specific-users-exchange-2013-help
#2
Jump to: