LockedCustomize Template seems to lose styles

Junior Member
2008/03/18 11:18:23 (permalink)

Customize Template seems to lose styles

I tried to go into My Server -> Customize Templates and edit one of the auto-signup templates. No matter what I do (even with no changes), when I save it and go back to look at it, there is no style info - as if all the stylesheet info is gone. I then restore it and everything is back to normal.

I know this issue was raised some time ago, but the forum post said this had been fixed. I have the latest build of HC7 running.

To troubleshoot, I tried copying the contents of the raw data from the SQL server text field and then copy that into the custom record's field. When I do this, I get a warning from SQL that this will truncate the data. I am wondering if the default size of my text fields is too small. I am running SQL 2005 Express. I wonder if that is why after each save, it breaks the template - because the data has been truncated.

Any ideas?

2 Replies Related Threads

    Junior Member
    RE: Customize Template seems to lose styles 2008/03/18 11:38:14 (permalink)
    OK. Here's some more interesting information on this issue.

    I looked at the raw HTML when I actually run the sign-up pages. The default page has a big chunk of stylsheet info up in the header. The modified page has that stripped away. I also looked at the raw data stored in SQL. The default data has everything there, including stylsheet markup. I then look at the modified page (in notepad), and the stylesheet markup has all been stripped away.

    So, it seems that when you save the template, it is stripping away the style info in the header. I am not sure why. If I try to manually edit the field data in notepad and then copy it back to the database, I get a data truncation error. I am most curious though as to why the style info is stripped away when saving within the control panel GUI.
    HC Team
    Hosting Controller
    RE: Customize Template seems to lose styles 2008/03/25 04:06:01 (permalink)
    We have investigated about this issue. Actually this issue was fixed few months before. It seems you are using Firefox as browser. If you are using IE and you are still getting this problem then please contact HC support with your server access to debugg it in detail. Thanks

    HC Support Team
    Jump to: